Tag Archives: Flashcard

Gateway 3ds Support for Firmware 9.0 – 9.2 Coming Soon

There’s been rumors from various sites that 3ds Gateway will support 9.x firmwares and new 3ds, and at last the Gateway Team has officially confirmed this on their site. The recently released SKY3DS cart, only had support for 9.x firmwares and the new 3ds. Even though it has its own …

Read More »

SKY3DS, a dream coming true or a hoax?

Lately, more news has emerged on several sites about this  3DS flashcard which seems to works on all 3DS firmwares. Currently all 3DS flashcards need firmware’s 4.1-4.5 and you are SOL if you have higher firmwares. This also means there is no way to use flash card for 2DS, N3DS, N3DS XL/LL …

Read More »