logo PlayStation Guide Beta
Facebook Twitter YouTube
How to make CMA backups for anyone (without linked PSN account)
<- go back


logo   How to make CMA backups for anyone (without linked PSN account)


Working for Firmwares: 3.00 - 3.52, 3.60

PlayStationTV compatible: Yes

Potentially Dangerous


Difficulty: Moderate

Time: approx. 10 min


Credits: Mr.Gas, Major_Tom

Requirements:
  • fixreg_vita 0.1 (35 kb)
  • any HEX Editor of your choice
  • a registered e-mail account on your Vita (fail-mail)
  • FileZilla (HENkaku)

  • Note: This process could damage your Vita and WILL delete your PSN activation!


    1 2


    Step 1: Getting your Vita's system.ireg & system.dreg file



    Depending on your firmware there are different ways to do this:


    Fail-Mail trick - for firmware(s) 3.00 - 3.52




    HENkaku - for firmware 3.60





    Step 2: Use fixreg_vita to read out the files



    1) Download fixreg_vita 0.1 if you haven't already and extract the archive.


    2) Now we are going to just drop our registry files next to the fixreg.exe

    fixreg

    3) Run the fixreg.exe the first time

    fixreg

    4) It should create a seg-folder for the various segments

    fixreg


    Step 3: The analyse and modify part



    1) Okay! Now just open the system.dreg with any Hex Editor of your Choice.


    And simply search for your AccountID / CMA backup ID as hex values via search option!

    button_assign

    Note: The offset varies depending on your Firmware Version!



    2) Change said values to whatever values you like and save.




    3) Now once again run fixreg.exe so that your changes get patched and the checksum is valid for the Vita

    The system_.dreg file is our patched registry file which we can now write back..



    Step 4: (Re)Installing the modified registry file



    Fail-Mail trick - for firmware(s) 3.00 - 3.52




    HENkaku - for firmware 3.60




    Note: Resetting the system settings will reset this!



    FAQ & Troubleshooting



    My Vita says fatal error after restarting!?!?

    Your Registry got corrupted. Just restore the default settings.


    My e-mail shows a [?] instead of the photo symbol?!

    Try resetting the Vita's mail account or resend the mail.




    Last updated:
    July 4, 2018